A cluster has occurred. Fonts still not activating (Fixed)

My original post (under a previous acct): “Using Fontbase for first time. I downloaded it and am considering a subscription – because I need to clean out my installed fonts and restore some order. But I have a folder of TT/OT fonts that are meant to replace Adobe Type 1 fonts that are no longer supported by Adobe. I opened those TT/OT fonts with Fontbase. It says they are open. I saw them turn green and they now appear under “activated.” But they are NOT available in InDesign to replace several Type 1 fonts. WTH? I’m on a deadline.”


PS I did restart InDesign, no activation. So I uninstalled FontBase, and went back to look for an answer … but had to create a new account at FontBase – because I evidently did not remember the login correctly.
When I clicked to activate my account, I was then forced by my apparent inattention, and your somewhat fussy login process, to create a new account, and was taken straight to a subscribe page (was given no other reach-able option)… so eff it, I subscribed. The download window said “Download for Mac.” WHAT? 1. Is FontBase a Mac only thing? If so, how did I miss that with all my roaming around your site? 2. If FontBase supposedly works with Windows 11, how do I make it work as advertised? Thanks :slight_smile:

PS somehow I created a new account, yet this is appearing under my previous usename. I swear I don’t eat mushrooms.

Hey. Not sure what’s goin on with the account thing, but we support Windows for sure, you can download the Windows version directly from here: FontBase — Download for Windows

I just can’t get it to work as advertised. Fonts are activated but not available within applications. Really tried to make it work! Finally gave up after two installs and uninstalled.

Update: Fontbase is workin now! I made sure I downloaded the Windows version (thanks Dominik!), and eveything works. No idea what was happening all those months ago.