Font activation problem

MacOs Monterey
Version 12.0.1
Apple M1 chip

FontBase Version 2.16.9

Hello everyone, I just installed some of my fonts in FontBase, and I can’t activate them, I have each time an error message “Could not activate X fonts”

My root folder containing the fonts is in the right place, the write and read rights are ok.

I am French and I use a translation tool, sorry if my English is bad.

Thanks for your help, Fanny.

Where is your root folder located at?

Hello Dominik,

My root folder is in macintosh HD
/users/baba.studio/FontBase

And I checked if the folder /Library/Fonts/FontBase exists on my system and it does not exist.

Hello,

I have uninstalled and reinstalled fontbase.
I put my fonts in the folder Users/name/FontBase or in the folder /Library/Fonts/FontBase nothing works… I have my 1500 fonts in the software and I cannot activate any of them.
But I have the same software, on my MacBook Pro with exactly the same fonts, with the root folder Users/name/FontBase and on this one everything works!
I don’t understand it… I absolutely need a font manager to work… I don’t see myself installing everything in the “font book” of the Mac :sob::sob::sob:

2020 Macbook Pro
MacOs Monterey
Version 12.0.1
Apple M1 chip
FontBase Version 2.16.9

I’m having the same problem except I can’t activate any fonts. I’ve tried changing the root folder and this will change which fonts appear in the library, but any font I try to activate gives me the error ‘Could not activate.’ Have tried de-installing and re-installing FontBase, but the problem persists. Will try updating to the newest version of Monterey. Could use help.

Hello everyone,

I might have the same issue.

2020 Macbook Pro
MacOs Monterey
Version 12.1
Apple M1 chip
FontBase Version 2.17.5

When I activate any fonts, nothing happens in the other app. I’ve tried ton uninstall the app, restart my computer, I’ve deleted the fonts then re-uploaded them on FONTBASE. And when I activate one of them, I can see the mention “Activated ## fonts”. But still, nothing happens.

I’ve already used FONTBASE on window10 and an old macBook Pro (on Sierra) and I don’t have these issues. Could there be a conflict between Monterey and FONTBASE ?

I’m having this same problem. I just installed Fontbase on a new PC, and set the root folder to where it lives (it’s in Google drive, so I have access to my font files from wherever I am). I did make sure the folder is available offline. Fontbase sees all of the fonts, but it fails to activate any of them.

I’m not on a Mac, but a PC

2020 Razer Blade 15
Windows 11
FontBase Version 2.17.5

Has there been a solution to this?

Apparently it’s to do with the Google Drive folder - I copied my Fontbase folder to my Desktop and set it as the root folder, and everything works fine.

Is there a way to use a Google Drive folder for this without setting Google Drive up to save everything locally (ie using “Mirror”, even when I set the folder as available offline)?

Hello @mandikaye, thank you for investigating the issue.
It appears the conflict is associated with how Google Drive implements their functionality.
At the moment it doesn’t seem like there’s another workaround besides the local copy solution I’m afraid.
We’re keeping an eye on this and will try to do something about it as soon as it’s an option.
Thank you again,
Yuriy
FontBase Dev Team

Hello @Smaug, thank you for the message and sorry for the delay in replying.
That’s a possibility, yes.
Also, does restarting the other application after font activation make any difference?
Is it just that one application that does no detect the activated fonts, or does it happen in every single application on your system (incl. text editors etc)?
This can help us understand what the issue might be.
Thank you again,
Yuriy

Hi @yuriy,
I tried to investigate on the issue few weeks ago with your coworker @dominik.
I had shared with him my screen and he had noticed that the file which was created by FontBase while uploading a font was not located in the right files of the device.

He had asked me to create a new user session, and it worked. But somehow, in the other session, it did not. I must specify that the computer was all new, so I can’t say the reason of the issue. That’s why, I decided to migrate all my datas and files in the new session.

To sum up, we could not figured it out properly :frowning:

Thank you for your answer anyway

Hi, has anyone else found a solution to this?

I have tried reinstalling Fontbase and also changing the root folder. Google fonts as well as my own fonts don’t seem to be able to be activated. This is not linked to any google drive setup.

Is this a permissions issue?

Hello @SOBN, thank you for your post and welcome to the forum:)
For now permissions do seem like the most likely cause of this behaviour, yes.

Hello
I have unfortunately the same issue with a new mac book pro.
Has someone the solution?
Thanks

The following worked for me.

The issue arose after I had migrated to a new MacBook Pro (M1).

  1. Renamed ‘Fontbase’ folder to ‘_Fontbase’ - I moved it to the desktop for good measure.
  2. Uninstalled Fontbase properly with Cleanmymac
  3. Downloaded and reinstalled Fontbase
  4. Renamed ‘_Fontbase’ folder to ‘Fontbase’ and moved it back from the desktop to Macintosh HD / Users / [Username] overwriting the new folder that had been created through the install.

All fonts and collections were back as before and all fonts could then be reactivated.

Hope that helps anyone.

1 Like

Hi there. Same problem here. Just installed fontbase. Suscribed for awesome fontbase. Added a few OTF fonts to test and activated them. Yet my Indesign or Photoshop won’t see any. This is hopeless. MacOS 10.15.7 Catalina.

Hello @mnedved, thank you for the post, welcome to the forum and sorry to hear you’re experiencing difficulties with font activation.
The situation is not necessarily hopeless, let me see if I can help.
What FontBase version are you using?
What are the InDesign and Photoshop versions?
Did you start InDesign and Photoshop and open respective documents after you’ve activated the fonts with FontBase or did you activate the fonts mid-use of CC apps?
Hope this helps,
Yuriy

FontBase 2.18.1 Awesome, Indesign 2023 18.0. I tried both ways. Activating fonts before launching app and later activating fonts when launched.