FontBase - won't open, remove IndexDB, then Awesome license won't load

Hello,

I recently purchased and installed FontBase on 5/2/23.

I spent time in FontBase tagging and creating collections. I hadn’t gotten through my entire library yet, but had made a dent.

Today, it will not open. Worked fine for 2 days.

maxOS Ventura 13.3.1 (a)

(May have auto-updated yesterday; is that the issue?)

FontBase - current version

I already tried:

  • clearing the font cache and restarting

  • backup of Application Support/FontBase/IndexedDB, then remove, and restarting

That opened FontBase, but signed me out of the premium Awesome license I purchased

  • If I replace any of the IndexedDB files to the new folder, FontBase won’t start again

How do I log back into the Awesome subscription that I purchased?

How do I retain the tags and collections that I spent hours setting up?

How do I fix this issue and avoid FontBase failing to start again in the future?

Hello – bumping this.
Issue still exists.
I paid for the premium, Awesome version and priority support.
After 2 days of working, it no longer logs me in with my Awesome license and all of my tags are gone. Details in original post.
Please advise

Hello @bei77, thank you for the post, very sorry for the delay :pensive: and welcome to the forum :pray:
About logging back in: what happens when you try the ordinary flow of hitting “Get more features” → “Login” → entering the login and password? You’ve mentioned 2 days - is your computer, with the application installed on it, connected to the internet during that time?
As for recovering the database: would you happen to remember which version you installed originally, before the initial crash and turning on auto-updates? Would it be possible to install the same old version, without the updates, and try to launch it with the backup database file?
As for the last one - using the latest FontBase version should deal with all the remaining issues :pray:
Thank you again,
Yuriy
FontBase Dev Team

Hi,
Originally installed version of FontBase is the same as the current one:
Version 2.18.1 (2.18.1)

I can log in ( thanks for your patience and the note — I tried again and double-checked my settings).

Previously set Tags, Collections, Favorites, etc are still not available,

Following directions from a different post on replacing current IndexedDB with the backup makes it so that the application won’t open.

Can my previously set FontBase info be replaced?

Any ideas as to what happened? And how to avoid it in the future?

I am hesitant to re-tag and organize my fonts again via FontBase, in case something like this happens again.

Please let me know if you need more information. Thanks!

Very sorry for the delay and thank you for the additional info :pray:
The only way of returning the previous data that I can think of is manually going through the entire database file and figuring out what exactly prevents FontBase from running properly. That would require you giving us access to the potentially corrupted database files (the IndexDB folder) and some time to figure it out. Would that be possible?
This shouldn’t happen at all, at least this is not a known issue or anything common from what I understand.
Thank you again,