New added fonts stopped showing in Fontbase

When I drop new fonts in my root folder, they do not appear in Fontbase.
I am running the free version with a total of 35,000 fonts.
This issue has started a couple weeks ago.

MacOs Ventura 13.4
Fontbase 2.12.1

Hello @DanJul, thank you for your post and welcome to the forum :pray:
Where there any changes to the setup during this time?
Was your Root Folder location the same before and after this started happening?
When you write “drop new fonts”, do you mean individual font files, or folders containing them?
Were there any changes to the OS, admin or access rights/privileges during this time?
Thank you again,
FontBase Dev Team

Hi Yuriy, thanks for your reply.

The root folder as not been moved or changed.
I’ve also deleted the app and preferences, re-installed and the issue remains.

I mean, if I had new fonts and folder with font in the Root folder, they do not show in the Fontbase app. The only way it works is if I manually drag-drop fonts in the Fontbase side panel (which causes font duplicates).

I don’t think there as been any changes on my Os and admin. Only recent change is if selected Fontbase to automatically open at startup (cpu).


Thank you for such a quick reply :pray: And sorry for the delay :pensive:
May I ask what exactly do you mean by “drag-drop fonts in the Fontbase side panel”?
Also, is you add a folder in FontBase itself, do you see this newly added folder in the Root Folder?
Thank you again,

Hi Dan,

Please excuse me if I am out in left field on this. I am not certain I understand your dilemma correctly. However, I do have 6241 fonts, in 1952 folders.

I started with a “mess” of over 40K files collected over decades. You prolly know the drill, alpha numeric names that are no clue to what the font family is or even what style. The dups, PS fonts, TT fonts, etc. To reorganize and weed my collection I used the “Watched Folder” option with FontBase. I created one root folder (outside) of FontBase structure, “Fonts Archive” and assigned it to be watched. As I worked through my files I created an individual folder for each family (clean, nothing but font files in the folder) and moved that into the “Fonts Archive”. FontBase always updates accordingly, while its running or the next time I start it.

Initially it took a lot of work to get what I wanted, but now its super easy to add the new fonts by dropping a new folder in the archive. I was concerned about the number of folders being an issue, to date, no problems.

Maybe some part of this comment can be of help to you!

1 Like

Hi Yuri,

I’ve been using Fontbase for many months now and everything worked fine.

Now, when I had fonts into the root folder, they do not show up in Fontbase (I can no longer see the new fonts I add in).

By drag-and-drop I mean, if I take a font from my download folder or a new font I have added in my root folder and drag it on the Fontbase viewer and drop in on the vertical side panel - that is the only way Fontbase see’s the new added font and it makes a duplicate which I don’t need.

The problem is that ANY new font if add in the root folder, it DOES NOT appear in Fontbase, so it’s impossible for me to activate it and use it.


Hi Dan, thank you for your reply :pray:
Could you please check if your Root folder path is indeed the one you think it is? You can see the current Root folder path in the Settings page. You’ve mentioned that you can drag a font from the Root folder into the FontBase window and it can be added that way. This is very odd behaviour.
Also, were you able to find an answer to my second question from the previous message?
Thank you again,

Hi Yuriy,

Yes it’s the same root folder. I have reset it again and the problem persists.
To your second question, I I drag a new font from my root folder onto Fontbase, it appears then.

At this point I guess I will have to drag in all new fonts I have … since they don’t update automatically.

Thank you for such a quick reply :pray: This is extraordinarily unusual
When you add fonts in this way, do you see them in the Root folder when you open it with your file manager?

Yes I see them and they are duplicated. Time to switch to another type manager, this is becoming too tedious and time consuming.


I’m really sorry about this :pensive:
Of course, your productivity and comfort should always be your first priority :pray:
Thank you for taking the time and effort to describe this in such detail. In the meantime we’ll keep chipping away at it to see how and why this can happen.
Thank you again,