Collection Sync + Google Drive as Root => Import Error, Export Error

  • Ventura 13.5.2 (22G91) (Intel Core i5)
  • FontBase Version 2.16.6 (2.16.6)
  • Google Drive Version (Intel)

I’m using a folder called FontBase inside Google Drive as a root for Fontbase. Inside this folder, I placed a subfolder to sync my downloaded fonts between my 2 computers. This works fine.

Now, I purchased “the awesome” for collection sync, which however fails.

Testcase 1:

Enabling the Auto-sync collections setting (or hitting import/export) while Google Drive is the root, consistently gives me an import/export error (see bottom screenshot left side).

Please note that I made the whole root folder available offline and waited until it fully synced with Google Drive.

Testcase 2:

I tried to change it to my local user FontBase folder to see if it’s Google Drive related and indeed, there are no more errors (see bottom screenshot right side).

However, there is nothing added to the root folder even in this case. Isn’t there supposed to be a JSON file or something similar?

Here’s a screenshot of both cases:

What can I do to further test this and get this to work? I wanted to create collections to organize my favorite local as well as Google Fonts.

When I’m home from the office, I will test on my second computer and report as well.

Interestingly, on my second Mac (11.7.9 (20G1426) BigSur), it works.

  • no error on activation of the setting
  • export button actually gives me a prompt with JSON file output

Two things that I noticed which are different.

a) the path to my Google Drive FontBase folder has a different path. It’s called /Volumes/GoogleDrive/Meine Ablage/FontBase – this may be related to the different OS version on this mac (Google Drive version is identical).

b) after activating the Auto-sync collections setting in FontBase, I was given a prompt to enter my password (“FontBase wants to make changes”). I did not receive this on my other mac (Ventura 13.5.2).

Maybe the app should have asked for permissions on the Ventura system and is not working because of that?

Hello @thomas, thank you for your post and welcome to the forum :pray:
And a separate thank you for so much info on the matter :pray: Sorry for the delay :pensive:
From what you’ve described it looks like it’s an issue with permissions. On the second computer you’re asked to approve the respective actions, while on the first one you’re not even asked this, most likely meaning the current user does not have the authority to approve this type of actions (writing files by installed software for example).
Upgrading/elevating the user authority, or giving them admin rights, if possible, should alleviate this issue.
Hope this helps,
And thank you again,
FontBase Dev Team

1 Like

Hi Yuriy,

I uninstalled the app (appcleaner) and reinstalled it, this solved the issue. I was confronted with the prompt and now it works.

One more thing though you should know: keeping fontbase in system start leads to the problem that fontbase seems to load before Google Drive is fully running (and I suppose the folder is accessible to fontbase). This leads to no fonts are actually activated and also my collections do not show up anymore. It won’t refresh or repair itself. Also, fontbase will most likely store this new (faulty) configuration on close.

Let me know if a log of some sort helps you.

Removing it from automatic startup and starting it manually AFTER google drive has loaded, solves the issue. My collections are there and the fonts are active.

Thank you @thomas for the quick reply :pray:
Regarding placing FontBase Root folder on the Google Drive - yes, unfortunately we have received reports of similar behaviour in the past. We are still in the process of figuring out how to make sure this issue is gone once and for all, really sorry for the inconvenience :pensive:
Thank you again,

1 Like