"Could not activate font"

Please include the flowing when reporting a bug:

MacOsX
Ventura 13.6.4
2.20.7
No font can be installed
A red button appears in the corner down right saying: Could not activate X font

I have had great pleassure using FontBase for over a year. I have the awesome licence. Suddenly late last year, 2023 FonrBase stopped activating addtional fonts. Redusing the number of fonts does not help. I have this problem on my mac at work, which in an Intel iMac from 2017. My MacBook Pro M2 does not have this problem.

I reinstalled FontBase this morning cleaned out preferences and all and there is no font activated, but still I get: Could not activate 8 fonts.

I was wondering if you had a clue what could be happening or how to resolve it.

1 Like

Hello @SiggiArmanns, thank you for your post and welcome to the forum :pray:
Does this happen to both the pre-loaded Google fonts and the ones added into FontBase from the hard drive?
Thank you again,
Yuriy
FontBase Dev Team

Hi. I thought I had answered your reply but I don’t see it here on the forum. The answer was that this problem was all over FontBase. I even reinstalled it and that resulted on no active fonts. I also mentioned that I was going to investigate permissions on the Fontbase folder when I had the time. The time case this morning. I made a new account and moved the fontbase folder as a whole over to the new account. When into the Get info and adde rw rights for Staff and made it do that down the line on all folders. That finally worked. I had tried to do this previously and also using Terminal but no luck. It seems to work great now.
The reason I suspected permissions what that I had gone into using RightFont which I have a license for but the fonts I added from the FontBase folder did work at first but then stopped working.
I am now back on my previous User.

You can close this discussion now but I think the solution should be visible.

Correction: FontBase as returned to the problem again, just after I reported what I thought was the solution. The search continues. Any tips are welcomed.

Hello @SiggiArmanns, thank you for your reply and the additional info :pray:
Did I understand correctly that making sure r/w rights are granted fixed the activation issue, but then activation stopped working at some point after that? Did something else change in the system?
Thank you again,
Yuriy

Yes, that was the odd thing.

The procedure was as follows:

  1. Made a new user
  2. Moved a copy of the FontBase font folder over to the new user and adding new fonts seemed to work fine when I logged in on the new user.
  3. Then I moved this duplicated FB over to the old user and activating some font sets I needed seemed to work.
  4. The day after when I wanted to continue nothing could be activated.
  5. This morning I reset the r/w for the old user to 755. Did not help either

I tried to repeat this procedure today but with no luck. I have cleaned out Font Base preferences. I will continue to try to solve this as I can.

Hello @SiggiArmanns, thank you for the quick reply :pray:
Any chance of trying 777 for the access rights?
From what you’ve described this really looks like a rights issue, or the OS, rather than something within FontBase itself :pensive:
Thank you again,
Yuriy

Yuriy.
I will try that after the weekend.
I have come to the same conclusion. It is not Font Base itself but something in the surrounding.

What I did yesterday morning was to log into the new User I mentioned previously. Font Base starts there (the same one I have trouble with) and it loads any font I need and is just working great.

Moving to a new User is a real pain so I would really like if 777 would work. We’ll see. Good idea. I always hesitate to let Everyone get full rights but it is worth the try.

1 Like

I am waiting to get time to test the 777 solution. I won’t be until after a week or so.
So far the new User account is working great for FontBase.

1 Like

Setting permissions to 777 did work to get FontBase back on course. I how ever decided to keep on with my latest User.
Thanks for the attention and help.

1 Like

Thank you for the follow-up @SiggiArmanns :pray:
Closing the topic for now