"Could not activate fonts"

Please include the flowing when reporting a bug:

Installed fontbase on new mb air m2, set the folder location to the right folder in settings but not able to activate any fonts. How to fix?

  • Your operating system
    Macbook Air M2 Ventura
  • Operating system version
    13.5.1
  • FontBase version
    2.18.1
  • What actions caused the issue
    Not sure
  • If possible, attach a screenshot

Hello @RalphAn, thank you for the post and welcome to the forum :pray:
The folder location (do you mean the Root Folder field?) - is it on a local drive? Do you have full read/write access rights to it as a user?
As for the notification itself - does this happen to any fonts at all, or just some specific ones?
Does this also happen on the pre-loaded Google Fonts?
Also, is this your first time installing FontBase on this computer?
Thank you again,
Yuriy
FontBase Dev Team

Hi @yuriy , Thanks for your message. Yes, I ment “Root Folder Field” which is a local folder indeed. Yes, I do have access/rights. It happens to all fonts. I transfered all of the applications from my old macbook, than Fontbase didn’t work so I uninstalled it and downloaded it again but it still doesn’t work. Kr

Thank you for the quick reply and for the additional info :pray:
This is very odd.
Would it be possible for you to reset Fontbase settings by doing the following:

  • uninstall FontBase;
  • make a reserve copy, then delete this folder “~/Library/Application Support/FontBase”;
  • install the latest app version downloaded from fontba.se
  • test font activation on the pre-loaded Google Fonts (requires an active internet connection);
  • then change the Root Folder directory to the desired one;
  • test again on Google Fonts or any of the fonts you used before;
    ?
    Hope this helps,
    Yuriy

Hi @yuriy, Tried to do it but I don’t have a Fontbase folder in ~/Library/Application. Uninstalled and installed again. Still the same issue

Thank you for the quick reply.
Interesting.
Could you please also check ~/Application Support/FontBase ?

PS Closing as being obsolete.