FontBase Won’t Open but I see it in my Activity Monitor

  • Operating System: MacOS Monterey (Brand new M1 MacBook Pro)
  • OS Version: 12.2.1
  • Fontbase version: Latest version (although I can’t open the app to confirm the version number)

Issue:
Ever since migrating to a new M1 MacBook Pro, FontBase simply won’t open. It appears to be running normally in Activity Monitor, but there’s no way to view the app window at all. When I use Activity Monitor to force quit FontBase, and click the app icon to open it again, the app window never appears. The only way to get the window to appear is to delete the ~/Library/Application Support/FontBase directory. When I do that I lose all my fonts, font collections, and settings. From there it works fine, but I have to re-sync the fonts each time and as soon as I close my computer or quit FontBase, the window disappears and I can no longer use the app forcing me to start over from scratch.

Screenshot:

Notice how there’s no indicator that the app is open under the app icon in the dock, despite Activity monitor showing it’s running.

I’ve read through all of the other similar topics and this doesn’t appear to be solved. Is it an issue with M1 compatibility?

Please help, as soon as you can.

I have an 2016 macbook pro and the same issue. I upgraded to Monterey a few weeks ago, and in the beginning it was working normally. Now i can’t open the application, but the activity monitor says, it’s still running. Therefore I don’t think it’s matter of the M1.

Yeah, you’re right.

I just tried it on my 2020 Intel Mac and I’m experiencing the same issue. I only just recently switched to Monterey so maybe thats causing the issue?

I’ve been a paid subscriber since 2019 and I’ve never had any issues until now. I use it professionally for business and this problem is really jamming me up. I may need to go with an alternative app until this gets fixed.

@dominik Hoping to get some help with this :arrow_up: issue, please.

force quit & try again?

Is there an icon in your system tray (top right bar)? There should be a small FontBase icon and you should be able to open it from there.

No, there was no icon in the system tray. I’ve seen it there in the past, but not since having this issue.

However, I’ve managed to get FontBase to work again after about 6-7 tries. I’m not exactly sure what worked, but its back now.

Here’s what I did which hopefully helps you trouble shoot this for others.

  1. The only way to get the window to show was to delete the Application Support directory as I mentioned above (idea found here).
  2. I keep my fonts synced across two Macs via an iCloud directory. I renamed the iCloud folder to something temporary so it wouldn’t create a conflict when updating the root directory in settings.
  3. After that, I ran the app and the window returned, but without any of my fonts or collections (expected)
  4. Next, I logged into my account, then went to settings and reset everything back to what I had before, including updating the root folder to point to my directory on iCloud.
  5. After that, I copied all the fonts out of that temporary directory into the newly created root folder and they all appeared in the app a few moments later. The only thing missing was all of my custom font Collections.
  6. At this point, I had the window open with all my fonts back so I figured it was back working correctly, but I was wrong.
  7. The next day, I restarted my Mac and sadly the app would not open again.
  8. I ran through steps 1-6 many times and it wasn’t until the last time that I tried resizing the app window to see if that had any effect.
  9. For some reason, resizing the app window made it possible to quit the app, and then run it again to see the app window as expected.
  10. It seemed things were back in order, but the only other problem was my font collections were still missing. To fix that, I decided to turned on “view hidden files” on and found the original JSON file that stored all my collections.
  11. I tried copying that file into the newly created FontBase directory on iCloud, but for some reason it had no effect. Even if I created new collections, the JSON file didn’t seem to change or update. I even opened the file in VS Code to see if there were some kind of error but I couldn’t find one.
  12. Shortly after, I tried turning on the “Auto-sync Collections” option and for some reason, that forced the app to reference my JSON collections file on iCloud, which brought back all of my font collections! I later realized I might have been able to import the JSON file via the settings pane, but it isn’t clear what file type the importer will accept. It only says pick a file but doesn’t specify the type of file or where it might come from so I didn’t make the connection.

All in all, the app seems to be back up and running for me now.

2 Likes

Most likely the deletion of Application Support folder did the trick. Thanks for the detailed steps!

2 Likes

Experienced the same issue running Fontbase 2.17.5 native M1 version on macOS 12.2 Mac Mini M1. The app shows it’s running on activity, but I can’t access it, restarting didn’t help.

Read through allancole steps and removed only the Application Support folder as Dominik mentioned did the trick.

The app now opens again. Just wanted to make you aware there are others also expericing issues with the M1 version of Fontbase.

1 Like

iMac 24", MacOs Ventura 13.0.1, FontBase 2.18.1

I’ve the same issue.
The only way to use FontBase again, as suggested by allancole, is to delete the folder “FontBase” in ~/Library/Application Support/ and restart.
Could the problem be related to the “Start at system startup” and “Start hidden” preferences? The bug seems to have started after turning on those preferences.

1 Like