Fresh Mac install, can't activate fonts

Hi! I’ve been testing your software to see if my team can use it, but when my boss installed it on his new Mac, he found himself unable to activate any fonts, including the Google ones. He tried uninstalling/reinstalling FontBase, but is still unable to activate fonts. Any ideas on what could cause this and how to fix it? All of his settings are the default settings and his root folder is on his desktop.

Please include the flowing when reporting a bug:

  • Your operating system: Mac OS Sonoma 14.4.1
  • FontBase version: 2.20.7
  • What actions caused the issue: unsure.

Update: We’ve tried following the reset tutorial on the main website (Reset Settings — FontBase Tutorials) as that was suggested in other posts with similar issues, but nothing happened.

We’ve also deleted ALL things FontBase related from his computer and uninstalled/reinstalled and that didn’t fix the problem either.

We also noticed that in his root folder, the google fonts folder only has 6 fonts in it, but all 6027 fonts show in the application. Don’t know if that’s helpful information or not.

Second update: I’ve tried to email FontBase support directly, but it gets marked as spam and won’t deliver. I’m out of ideas on what to do. Please help. :frowning:

Hello @mready8991, thank you for your posts and welcome to the forum :pray:
This is indeed useful info, as it shows that font activation process starts as it should (for the pre-loaded Google fonts they are first downloaded, then activated).
Is it possible that some other software is blocking FontBase, or its permissions are limited?
Thank you for already trying to reset the settings, this helps narrow down the list of possible reasons :pray:
Could you please specify what you mean by “unable to activate fonts”? What exactly happens after the activation toggle is clicked?
Thank you again,
Yuriy
FontBase Dev Team

To specify: My boss installed fontbase on his Mac (brand new Mac, he received it a few days prior to this event). When he clicks the activation toggle it says “could not activate x fonts.” Sometimes the circle will spin and sometimes the error message is instant. He can add fonts/folders, but those won’t activate either. Screenshot below shows the error message.

There isn’t any software blocking FontBase as far as we know. We checked for permissions but didn’t see any. What permissions should FontBase have? And where can we find/assign them?

While we looked for permissions, we did give FontBase the “Accessibility” permission and relaunched FontBase and were successfully able to activate a Google font (Abhaya Libre), but didn’t see it in Adobe Illustrator and could not deactivate it nor could we activate another font, instead we got the red “could not deactivate x fonts” and “could not activate x fonts” error messages. We relaunched FontBase again and were able to deactivate Abhaya Libre but not able to activate any other fonts. After further investigation, it seems as though he can activate/deactivate fonts within the first 10 or so seconds of FontBase being relaunched.

Hello @mready8991, thank you for the quick reply and the so much additional investigating :pray:
The good news is that something external to the app was indeed blocking it (the Accessibility permission).
The bad news for now, however, is that from the behaviour you’ve described it doesn’t look like there is anything within FontBase that could cause this issue, as there is no difference for it between the first seconds after launch and the subsequent time frame.
Does the activation/deactivation failure also occur on non-Google fonts that are added into FontBase after installation?
Thank you again,
Yuriy

Hey @yuriy,

The activation/deactivation failure occurs on all fonts.

We will do more testing to see if we can find what’s blocking it and add/remove permissions again. Unsure of what will happen, since giving FontBase access to the Accessibility permission didn’t seem to much for very long, but our fingers are crossed! We would greatly appreciate any additional suggestions or solutions you may have. I’ll update this thread once we do more testing and troubleshooting.

1 Like

@yuriy Update: We tried a few things this time. Unfortunately none of them worked.

First we went and gave more permissions. This time, we gave the FontBase folder all read/write permissions. Then we looked to see if we could give FontBase the “full disk access” and/or “files and folders” permissions, but found ourselves unable to. Does the FontBase app require those permissions?

Next, we tried moving the root folder again, but this didn’t do anything to resolve the issue. We tested FontBase with the root folder on his local desktop and on our own internal server, but we couldn’t activate/deactivate any fonts in either location.

Finally, we were going to try to install an older version of FontBase, but couldn’t find a download link on the website. Is there somewhere that I can find the older versions of FontBase?

In conclusion, we were unable to find a solution to the issue at hand. Do you have any leads or ideas as to what we can do next? Would it be possible to schedule a call a developer or whomever would be best to help in this situation?

Hello @mready8991, thank you for the additional research on the matter and sorry it didn’t work out :pensive:
You can find older FontBase versions here in the Updates section of our website: FontBase — Update History
Have you perhaps tried installing FontBase on any other available machine to see if this behaviour would replicate?
As for the call - please give me some time, I’ll see what I can do :pray:
Thank you again,

@yuriy Thank you for the link, we will try other versions either today or Monday. We have not tried putting it on a different Mac, we have tried it on Windows PC and it works just fine with minimal issues. We will also try seeing if anyone else has these issues on their Mac.

I will add an additional update once we troubleshoot again.

1 Like