Missing font and localisation(locl) from Google

Hello,

Just installed and subscribed to FontBase (using v2.18.1 on macOS Ventura 13.1 - clean install, no local fonts beside system defaults)

I was tagging the Google Fonts supporting localised Bulgarian Cyrillic forms and I came across two inconsistencies

Marmelad as displayed in FontBase is missing its localised Bulgarian Cyrillic version (manually pressing the localised forms button (locl) from the OpenType features menu does nothing).
Unbounded (also has BG local forms) is missing completely/not showing

All other fonts from Google supporting Bulgarian Cyrillic show as expected - my system is configured with Bulgarian as primary language in the preferred language list, so Cyrillic text entered in FontBase is automatically detected as Bulgarian and fonts supporting it will use the locl form by default, no need to toggle the locl option/button.

Thanks for reading!

Hello @clbrn, thank you for such an extensive check and welcome to the forum:)
I believe this behaviour is due to Google providing slightly different versions of some font files via their main Google Fonts page and via integration with other apps. Not sure if we can fix this at our end at the moment, but we will keep this case in mind while working on future improvements.
Thank you again,
Yuriy
FontBase Dev Team

Hi! I wanted to contact Google for quite some time over some different issues, so I’ll probably hit them up with a message regarding this, too :slight_smile: Hopefully such inconsistencies could be resolved. What about font list update to include Unbouded (another new missing font is Sofia Sans, for example). Thanks!

We’ll definitely update the Google font list in the next release, hopefully the inconsistencies will be resolved then, at least most of them:)
Thank you again for bringing this up

1 Like

Thank you! I wonder if Google Fonts has an API or something which could auto-update the font list…