Problems setting up Fontbase

I have just moved over to Fontbase from Suitcases. I am using a MacBook Pro (late 2014) and Mac OS11.4 (Big Sur). I have had a few issues:

  1. I have no idea how this happened but my applications folder, including all of the applications has appeared in Fontbase and I can’t find a way of deleting it.
  2. In addition I don’t seem to be able to add any of my own fonts. The only fonts in there are the Google fonts. It’s really important I can access my own fonts.
  3. I tried to delete the app and reinstall it in order to get rid of the eronious applications folder (see 1 above), but even when I have deleted the FB application from the trash can, when I reinstall it the same folders appear. Is there a way of starting completely from scratch.
  4. I’m assuming because of the problems caused by (1) above Fontbase keeps crashing.

I seem to have got off to a bad start with this software, which is a shame because it looks really good and I don’t want to have to go back to Suitcases if I can help it. Any help would be greatly appreciated. Would it miraculously all become much easier if I pay the subscription??

  1. Probably you have moved your FontBase root in the settings or you have dragged and dropped the applications folder into the FontBase window. Try right clicking the folder and the Folders section and delete it.

  2. Have you tried the plus icon on the bottom left of the FontBase window?

  3. See 1.

  4. Most likely, yes.

  1. I have tried that, but somehow the fonts in some of the Adobe applications are ‘activated’ and I can’t deactivate them and can’t seem to delete any of the folders, even the ones without activated fonts.
  2. Yes, I tried that. All of the ‘A’ fonts before ‘Applications’ appeared have appeared in Fontbase, but I can’t activate them. Nothing after that appeared (B-Z). I suspect the problem might be with (1) above, so if I can solve that in another way then I can prob sort out (2) and (4).

Pretty confused about what’s goin on there, sorry. Can you record a video?

Yes, here it is.

Thanks! Any advise would be greatly appreciated. Otherwise I’ll have to revert to using Extensis Suitcase Fusion :slightly_frowning_face:

You should be able to open the FontBase root folder in your system and delete the copied Applications folder manually.

Hello, there; this is an observation as I’m not on a MacOs, but it seems that you have added your drive to one of the options in add folder, and it’s scanning all your hard drives.

Until it does not finish loading all, you will not be able to remove it.

Exit the application and uninstall and reinstall when you do so it will not remember your added folders unless you added them to the fontbase/provider/

Disclaimer: This is how it works on PC. I’m just advising on what I can see might have happened. I hope it helps - I have been using another application for many years, and it works fine with great features - FontBase is faster and works with Adobe to load font automatically, which is a feature that most if not all have stopped creating.

My Setup > path: root folder> OneDrive>Fontbase> “so I have it on both my Laptop and Desktop”

Within the FontBase folder, there is a folder called “Provider” inside. I have added my different font folders, i.e., Google, Design Cut, Pro Fonts etc.

These are font folders organised and managed, so there is no need to add or remove them.

I will have a Watch Folder to add new fonts as I get them.

I hope this helps.
Chis

1 Like