Some Google font are missing

MacOS Big Sur - Version 11.2.3
FontBase Version 2.16.0

When I look for Montserrat (Google Font) in my FontBase, there is only 8 styles, but on Google Font there is 18 styles. Maybe my FontBase doesn’t sync the complete Google Font Provider folder? How can I resolve this?

I tried uninstall/install the app, restart my Mac, doesn’t solve the issue.


What’s the number of your Google fonts? It should be 3032. If it’s not, try deleting the Google provider and then add it again.

Hi there!

950 Google fonts, how do I add the Google provider back once it’s deleted?

You can right click the Providers title to do that.

Same here. On Google Fonts I find 6 styles (variable) for Cinzel and on Fontbase is showing only 3 styles.

Tried to remove and add Google Fonts as you told. No success. Also, Google Provider showing 3032 fonts.

Any ideas?

If tis is about some newer added Google fonts, it might be that we haven’t added the to FontBase yet. We do that manually between updates.


Deleted Google collection, re-added and all fonts showed up. FYI, had to reactivate all google fonts from previous set (PIA warning)

Actually do the same again and you now will find 3795 Google fonts (march 6-2022) :grinning:

It’s now July 25, 2022 and there are still only 3795 Google Fonts. Suitcase shows 5107. That’s a huge difference.

Hello @troyjack, thank you for your post and welcome to the forum:)
The updated list of Google fonts should be available in the next release.
Thank you again for pointing out the difference.
FontBase Dev Team