Collection sync isn't working with Google Drive

I’m having trouble getting collection sync to work. I’m probably just misunderstanding how it’s supposed to work, but I read the directions and followed them the best I could, and it’s just not working. Basically I want to be able to access the collections I set up on my laptop from my desktop computer. I installed Google Drive on my laptop and my desktop, moved the root folder to its own folder on Google Drive on both devices, and turned on “Auto-sync collections” on my laptop, but I just got an error message saying “Collection import error”. Am I missing something? After I moved the root folder to Google Drive, there are still no files in it. I also tried “Export collections” and then got "Collection export error, and I tried “Import collections” and got “Collection Import Error” again.

When you’re trying to add any fonts or folders to FontBase, are they appearing in the root folder in your Google Drive?

Yeah the files have now shown up in the root folder in the Google Drive, but I’m still getting the import/export error messages.

Update: I tried using a network drive instead of Google drive, and I’m still getting the “Collection import error” message when I try to turn on auto-sync.

Hello there,

I been reading your post and although I am not in Google Drive I have it set up on OneDrive. I just want to get a few things straight.

When you say collections you mean the groups you create yourself.

If so go to the FontBase/.fontbae/collection.2.16.4

Delete it then go back to the app and try exporting again.

If it works you will have a new collection.2.16.4 file

Then you should be able to sync.

I had this issue when experimenting setting this up and had issue with that file.

Deleting that file will not affect your collections.

Hope this works out for you.

There’s nothing in my .fontbase folder, it’s empty.

1 Like

Hello there, I’m shooting blind here as I don’t have a local network storage.

Your going to find hard coming up with a solution as its not very common setup.

  1. Have you tried reinstalling the application?

  2. Have you tried a test run locally (you don’t need to move everything) just copy some font to the default local and try exporting.

  3. Network drives sometimes power down and have protocols that may stop information exchange write permission ext.

I be looking forward to you response it be interesting to see what results are.

This sounds like some issue with access rights. Can you try to move your root folder to your local drive, instead of the network folder and see what happens when you export collections then?

That time I got a “export successful” message. That won’t let me sync up my devices though, right? The only reason we tried with the network drive was because google drive just wasn’t working.

No it will no let you sync if its not accessed by other devices. I see you have OneDrive if you have enough space on it try it there, not sure what size is your font collection.

That’s how I have it set up. /OneDrive/FontBase This gives me access to the same set of fonts that I added to to the folder fontbase/Providers/

I add them to Provider to keep them in the Groups I had them before.

I then installed it on the laptop and changed the root location to point to /OneDrive/FontBase after a few minutes I had access to the same fonts.

Then you export collections and sync them, just have to remember that collections are hand made groups where providers are folders where you but your fonts by founder or collections you sorted out before.

Hope this helps

If it works on your local drive, and does not work in network, most likely FontBase does not have enough access rights to write to the network folder. It may actually be a bug on our side. We will need to investigate this.


Quick update: I was able to finally get this to work by using OneDrive, but I would have much rather used Google Drive since I already use that for everything and I had never used OneDrive. Regardless, thank you both for your help!


I had a similar problem. Here’s what fixed it for me:

1 Like